The Wireshark 3.2.3 released and comes with fixes for various vulnerabilities. Some of them have a problem with the BACapp dissector.

Wireshark is the most popular network protocol analyst in the world. It is used to deal with problems, analysis, planning, and training.

It is used by network administrators to troubleshoot network problems and by security, analysts to examine data. Wireshark is used by many organizations.

For¬†macOS¬†users¬†with Wireshark 3.2.0, automatic updates may not be performed.¬†The¬†users¬†must¬†install updates “Hera”¬†(manually) to make sure you stay safe.

wireshark 3.2.3

Vulnerability corrections

As mentioned above, there is a vulnerability that affects the BACapp dissector. An attacker could exploit the vulnerability by introducing a malicious package into the network and deceiving network administrators, leading to the crash of the BACapp dissector.

Vulnerability can be corrected by upgrading to versions 3.2.3, 3.0.10, 2.6.16 or later.

Protocol Update and File Support

Protocol update: AFS, BACapp, Bluetooth, CoAP, Diameter3GPP, F5 Ethernet trailer, GSM RLC MAC, ISIS, ISIS CLV, ISIS HELLO, ISIS LSP, ISIS SNP, NAS 5GS, NR RRC, pcap, QUIC, RPCAPE, RTC / IP-SD, TLS, and WSP.

Correction of other errors

The new version of Wireshark includes corrections for many other errors that cause different problems. The errors are listed below (more details on each error can be found in the references).

If you’re interested, you can download the new version of Wireshark 3.2.3 here .

Education

As we said above, education is also offered. There is the Master in Wireshark Network Analysis, which helps someone to receive complete training for analyzing network protocols with Wireshark.

1 COMMENT

Leave a Reply